proUBC
Search…
⌃K

proUBC Prerequisites

Recommended resources for initiating your proUBC journey

Required prerequisites

abapGit. Instructions for installing abapGit are provided here: https://docs.abapgit.org/guide-install.html.
SAP system - ABAP developer authorization required to install proUBC and carry out needed configurations
SAP GUI Logon Pad for Windows or Java - Used to connect to SAP directly from your PC

Other Recommendations

PRVD CLI. Instructions for installing and using the PRVD command line interface can be found here https://docs.provide.services/api/quickstart/cli-quickstart
Postman - Used to verify API endpoints. Postman can be downlo
Eclipse with ABAP Developer Tools Helpful for ABAP Development overall! Needed for CDS views and any objects using the RESTful ABAP Programming model.
Fully activated SAP instance Essentially means your SAP system has transactional and master data ready to create purchase orders and sales orders. If you are using the developer trial edition - the EPM Demo scenario should be sufficient.

SAP Release Level

proUBC was developed and tested on S/4 HANA 1909, 2020 and ABAP 1909 Developer edition (RIP).
Older/Newer versions of SAP and ABAP Steampunk are not yet tested.